V36.0.3 released

bunch reliability work recently, so not much in terms of new features here

features I remember

  • can now game.enter({ isNpc: true }) and the front end won’t try to load their a/v, so bots don’t have the perpetual “connecting…”

breaking changes

  • game.chat now expects the fourth argument to come in as an object, ({ contents: "my message" }) rather than the string itself (e.g. "my message")
    • this is as we add more options to chat messages… coming soon!

Thanks for the update, I tried it!

isNpc: I really like it - thank you & works

game.chat: I think it is contents (not content)?

1 Like

oop thanks, typo. updated!

1 Like

@npfoss heya! I was experimenting with the websocket API, and notice we cannot longer make another person move.

Is there a way to do that in v36?
Thank you!!!

that is definitely supposed to work. you’re sure what you’re doing works in v34? if it doesn’t work there, more likely a bug on your end, like missing permissions or something

I’m getting this error:

[error from gs] 403: Client does not have permission to modify another player

And i am using this call:

game.move(MoveDirection.Up,false, "some api key")

Never tried v34 but it was working on v35. Now it does not work neither in

    "@gathertown/gather-game-client": "^35.1.0",


"@gathertown/gather-game-client": "^36.0.0"

I am the owner of the space and using my key. I tried with my character and others, but the error is the same.

I did a quick check and the code looks right and doesn’t seem to have changed, but I definitely want to give this a thorough investigation since it’s a big breaking issue – can you double check your permissions and start a new forum thread with the full code example please? So we can get to the bottom of it without spamming this thread

It works now… I think someone was playing with permissions. Thank you for your time!!!